summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCaio Oliveira <caio.oliveira@intel.com>2021-12-15 01:30:36 -0800
committerMarge Bot <emma+marge@anholt.net>2021-12-15 23:28:09 +0000
commit49c356a3356fbbe180ab9ec1027e744850550e53 (patch)
treeb0b299bad60ca1a516be9fcee241f5116d521448 /meson.build
parentdcc7b19cae924ecbcee88186a11df0290e5c7a8e (diff)
meson: Bump version required for gtest protocol
The feature was added in 0.55 but there was a bug when tests crashed (and no XML file was generated) that was only fixed in 0.59.2. Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Acked-by: Daniel Stone <daniels@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14204>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c987073b537..07ef92dbff8 100644
--- a/meson.build
+++ b/meson.build
@@ -30,10 +30,11 @@ project(
default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c11', 'cpp_std=c++14']
)
-# For meson >= 0.55.0, meson can inject some extra arguments to get richer
-# results from gtest based tests.
+# In recent versions, meson can inject some extra arguments to get richer
+# results from gtest based tests. Feature was added in 0.55, but requiring
+# 0.59.2 to include an important fix. See https://github.com/mesonbuild/meson/pull/9283.
gtest_test_protocol = 'exitcode'
-if meson.version().version_compare('>= 0.55.0')
+if meson.version().version_compare('>= 0.59.2')
gtest_test_protocol = 'gtest'
endif