summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2019-05-07 21:47:40 -0500
committerMatt Turner <mattst88@gmail.com>2019-06-19 12:16:18 -0700
commit10e8d466011076a0453368cb976d9f6b06af0e94 (patch)
tree25078294e5ff38bc2f4210b1cb2f9a0bbe36151f /meson.build
parentfd7b7f14d857f96cf3b2e9d8405dbbfa30dc261a (diff)
meson: Search for execinfo.h
Rather than checking __GLIBC__/__UCLIBC__ macros as a proxy for execinfo.h presence, just check directly. This allows the build to work on musl. Reviewed-by: Matt Turner <mattst88@gmail.com> Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a2978117409..a0c965efc32 100644
--- a/meson.build
+++ b/meson.build
@@ -1036,7 +1036,7 @@ elif cc.has_header_symbol('sys/mkdev.h', 'major')
pre_args += '-DMAJOR_IN_MKDEV'
endif
-foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h']
+foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h']
if cc.compiles('#include <@0@>'.format(h), name : '@0@'.format(h))
pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
endif