summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRob Clark <robdclark@chromium.org>2020-12-05 12:46:43 -0800
committerMarge Bot <eric+marge@anholt.net>2020-12-10 16:48:36 +0000
commit6fe84c5dda2f5935787c428347cf16ec1b1a5a30 (patch)
treec082a9844ce647f658e9d71c3a7782cc85633ad5 /meson.build
parent5a082911cdaf9a7b04d14c8ec60ad83cd063a524 (diff)
util: Allow STATIC_ASSERT() everywhere
Remove -Werror=vla from c_msvc_compat_args so we can use STATIC_ASSERT() in core code. We have a CI job for this. (And arguably we could probably just drop c_msvc_compat_args entirely.) Signed-off-by: Rob Clark <robdclark@chromium.org> Acked-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7941>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6118efc6dc1..a925746a654 100644
--- a/meson.build
+++ b/meson.build
@@ -1090,7 +1090,7 @@ else
# Check for C and C++ arguments for MSVC compatibility. These are only used
# in parts of the mesa code base that need to compile with MSVC, mainly
# common code
- foreach a : ['-Werror=pointer-arith', '-Werror=vla', '-Werror=gnu-empty-initializer']
+ foreach a : ['-Werror=pointer-arith', '-Werror=gnu-empty-initializer']
if cc.has_argument(a)
c_msvc_compat_args += a
endif