summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarek Olšák <marek.olsak@amd.com>2018-07-01 15:50:51 -0400
committerMarek Olšák <marek.olsak@amd.com>2018-08-03 18:36:11 -0400
commitfd1121e8399ef1439a6a1cec8246b970cceac7fa (patch)
tree9d08358419c9c3287cbcb1034010cb4dd196dab9 /meson.build
parent461a864316d5b70ea99c9e1dba7d71973af2aacc (diff)
amd: remove support for LLVM 5.0
Users are encouraged to switch to LLVM 6.0 released in March 2018. Reviewed-by: Timothy Arceri <tarceri@itsqueeze.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9a15c8ae3f2..cbaee5ceb22 100644
--- a/meson.build
+++ b/meson.build
@@ -1151,7 +1151,9 @@ if with_gallium_opencl
llvm_optional_modules += ['coroutines', 'opencl']
endif
-if with_amd_vk or with_gallium_radeonsi or with_gallium_swr
+if with_amd_vk or with_gallium_radeonsi
+ _llvm_version = '>= 6.0.0'
+elif with_gallium_swr
_llvm_version = '>= 5.0.0'
elif with_gallium_opencl or with_gallium_r600
_llvm_version = '>= 3.9.0'