summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2018-02-23 19:32:01 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2018-08-08 13:37:09 +0100
commit4f2b73d9fd0026aab2d9f5164af0d8f35eb57fa2 (patch)
treef04e33ff3d6fedc95c9b2dc6fe33f1d55c5af1ce /meson.build
parenta7ea7511ba76c0a83eec84dfc9c14c82b5c82dc4 (diff)
meson: recommend building the surfaceless platform
It has no special requirements, size and build-time is effectively zero. v2: Rebase Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Acked-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 661cbba9b43..334cf96ae70 100644
--- a/meson.build
+++ b/meson.build
@@ -304,7 +304,7 @@ elif _egl == 'true'
elif not with_shared_glapi
error('EGL requires shared-glapi')
elif not with_platforms
- error('No platforms specified, consider -Dplatforms=drm,x11 at least')
+ error('No platforms specified, consider -Dplatforms=drm,x11,surfaceless at least')
elif not ['disabled', 'dri'].contains(with_glx)
error('EGL requires dri, but a GLX is being built without dri')
endif