summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSerge Martin <edb@sigluy.net>2020-08-23 07:57:12 +0200
committerSerge Martin <edb@sigluy.net>2020-09-26 11:06:42 +0200
commita3543adc2628461818cfa691a7f547af7bc6f0fb (patch)
treea854721c70dfe9d2c6a03a643ff76d196844adab /meson.build
parentbf80fb7c3098d4e03b11971238bec51954cd0a30 (diff)
clover: set LLVM min version to 8.0.1
It also bump from 8.0.0 to .1 for AMD gallium and VK Reviewed-by: Francisco Jerez <currojerez@riseup.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6336>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 50e105efa55..76f72a9df7c 100644
--- a/meson.build
+++ b/meson.build
@@ -1450,8 +1450,7 @@ if with_gallium_opencl
]
endif
-with_opencl_spirv = _opencl != 'disabled' and get_option('opencl-spirv')
-if with_amd_vk or with_gallium_radeonsi or with_opencl_spirv
+if with_amd_vk or with_gallium_radeonsi or with_gallium_opencl
_llvm_version = '>= 8.0.0'
elif with_gallium_swr
_llvm_version = '>= 6.0.0'
@@ -1545,6 +1544,7 @@ elif with_gallium_opencl
error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
endif
+with_opencl_spirv = _opencl != 'disabled' and get_option('opencl-spirv')
if with_opencl_spirv
chosen_llvm_version_array = dep_llvm.version().split('.')
chosen_llvm_version_major = chosen_llvm_version_array[0].to_int()