summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Tang <tangm@microsoft.com>2020-12-21 14:58:47 -0800
committerMichael Tang <tangm@microsoft.com>2020-12-22 13:28:21 -0800
commit67e48bee1e642f83e751d1517c75e1dea0a56755 (patch)
treee50222073c719bacf6b8e22c2bba5b31220e2f59 /meson.build
parent050241d81a1854f98c18be7cca2281a2c3d99be4 (diff)
microsoft/compiler: Add dedicated spirv_to_dxil libraries
Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Reviewed-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8043>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a3ea925ddd5..a82a54e4a96 100644
--- a/meson.build
+++ b/meson.build
@@ -312,6 +312,8 @@ dep_clang = dependency(
with_microsoft_clc = dep_clang.found()
with_clc = dep_clang.found()
+with_spirv_to_dxil = get_option('spirv-to-dxil')
+
if host_machine.system() == 'darwin'
with_dri_platform = 'apple'
pre_args += '-DBUILDING_MESA'