summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJesse Natalie <jenatali@microsoft.com>2020-11-18 18:27:07 -0800
committerJesse Natalie <jenatali@microsoft.com>2020-12-02 10:12:27 -0800
commit425cfcafb20ab91669e2a080f4b095111d62969f (patch)
tree7241d80c44f9a79988fde65a7448215dba9d7e21 /meson.build
parent60454a4e990e2469846cfa07cf495a4bf5751207 (diff)
clover: Add opencl-native build flag
This flag controls whether to include native codegen functionality for the AMD backend Reviewed-by: Francisco Jerez <currojerez@riseup.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7680>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f51bc66cb1b..6d1607c35a3 100644
--- a/meson.build
+++ b/meson.build
@@ -1611,7 +1611,10 @@ else
dep_llvmspirvlib = null_dep
endif
-if (with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or
+with_opencl_native = _opencl != 'disabled' and get_option('opencl-native')
+
+if (with_amd_vk or with_gallium_radeonsi or
+ (with_gallium_opencl and with_opencl_native) or
(with_gallium_r600 and with_llvm))
dep_elf = dependency('libelf', required : false)
if not dep_elf.found()