summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2021-04-09 09:49:49 -0700
committerMarge Bot <emma+marge@anholt.net>2021-12-03 23:53:06 +0000
commit184a690fca700aa9ef2ae2e58b0f4bd86562aa6d (patch)
tree0e420f4877711d8b7008890f52b9c3625a84e14d /meson.build
parent4d45b280bf9a1c804cea5de4d15c317b6bdebfc5 (diff)
classic/r200: Delete driver
This will now only be available on the Amber branch Reviewed-by: Emma Anholt <emma@anholt.net> Acked-by: Jason Ekstrand <jason@jlekstrand.net> Acked-by: Kenneth Graunke <kenneth@whitecape.org> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10153>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 7fcd0656415..03e7aeedec7 100644
--- a/meson.build
+++ b/meson.build
@@ -178,11 +178,11 @@ if dri_drivers.contains('auto')
if system_has_kms_drm
# TODO: PPC, Sparc
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
- dri_drivers = ['i915', 'i965', 'r200', 'nouveau']
+ dri_drivers = ['i915', 'i965', 'nouveau']
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
dri_drivers = []
elif ['mips', 'mips64', 'riscv32', 'riscv64'].contains(host_machine.cpu_family())
- dri_drivers = ['r200', 'nouveau']
+ dri_drivers = ['nouveau']
else
error('Unknown architecture @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
host_machine.cpu_family()))
@@ -198,7 +198,6 @@ endif
with_dri_i915 = dri_drivers.contains('i915')
with_dri_i965 = dri_drivers.contains('i965')
-with_dri_r200 = dri_drivers.contains('r200')
with_dri_nouveau = dri_drivers.contains('nouveau')
with_dri = dri_drivers.length() != 0
@@ -1597,8 +1596,7 @@ _drm_ver = '2.4.109'
_libdrm_checks = [
['intel', with_dri_i915 or with_gallium_i915],
['amdgpu', (with_amd_vk and not with_platform_windows) or with_gallium_radeonsi],
- ['radeon', (with_gallium_radeonsi or with_dri_r200 or
- with_gallium_r300 or with_gallium_r600)],
+ ['radeon', (with_gallium_radeonsi or with_gallium_r300 or with_gallium_r600)],
['nouveau', (with_gallium_nouveau or with_dri_nouveau)],
]