summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2020-09-09 16:43:02 -0700
committerMarge Bot <eric+marge@anholt.net>2020-10-14 16:54:59 +0000
commitf51ce21e4e0bf7efabe58afb4a2cd6b9f98d9505 (patch)
tree48c30447034e94beebb56f41b2df17e54c9c952c /meson.build
parentd5a72319d6b8fa316608b5b93ac421f54716b674 (diff)
meson: Drop adding -Wl,--gc-sections to project c/cpp arguments.
We already have the targets we care about doing this using ld_args_gc_sections, and by adding it to project arguments we caused warnings spam in the android clang build about the compile stage not using the argument. Reviewed-by: Kristian H. Kristensen <hoegsberg@google.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6700>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 02a69c420c7..cfe02fa6373 100644
--- a/meson.build
+++ b/meson.build
@@ -1819,7 +1819,6 @@ endif
# drop shared code unused by that specific driver (particularly
# relevant for Vulkan drivers).
if cc.has_link_argument('-Wl,--gc-sections')
- add_project_arguments('-Wl,--gc-sections', language : ['c', 'cpp'])
foreach a: ['-ffunction-sections', '-fdata-sections']
if cc.has_argument(a)
add_project_arguments(a, language : ['c', 'cpp'])