summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTimothy Arceri <tarceri@itsqueeze.com>2020-07-01 13:37:14 +1000
committerMarge Bot <eric+marge@anholt.net>2020-07-02 23:52:53 +0000
commite2209e869a5560cb12de040aa5f9db4a305111e8 (patch)
treeb5bae138b377f6403335c91a556294d80cc543f3 /meson.build
parent26aa02b5ab99bb88a490410b55d357a004d5436b (diff)
meson: turn on Wimplicit-fallthrough project wide
This will help avoid coding errors and allows for less warnings from some static analysis tools. Reviewed-by: Marek Olšák <marek.olsak@amd.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/5705>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7d0373f3753..043047ddbea 100644
--- a/meson.build
+++ b/meson.build
@@ -991,6 +991,7 @@ else
'-Werror=empty-body',
'-Werror=incompatible-pointer-types',
'-Werror=int-conversion',
+ '-Wimplicit-fallthrough',
'-Wno-missing-field-initializers',
'-Wno-format-truncation',
'-fno-math-errno',