summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2019-09-08 13:14:40 +0200
committerMarge Bot <eric+marge@anholt.net>2020-10-20 17:58:45 +0000
commit442a7696004c5998d84a3df07d37fa9064dba214 (patch)
treef86b4e2406b5d670a6040c39a6ff18aebfbe2366 /meson.build
parentd0f8fe5909107aa342f62813ced9ce535ed6da32 (diff)
meson.build: xxf86vm is not needed for -Dglx-direct=false
It is only used in src/glx/glxcmds.c and when GLX_DIRECT_RENDERING is defined. So only depend on it if GLX direct rendering is actually enabled. Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/1905>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3cb3c904927..f1e4118fd5d 100644
--- a/meson.build
+++ b/meson.build
@@ -1779,7 +1779,9 @@ if with_platform_x11
if with_glx == 'dri'
if with_dri_platform == 'drm'
dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
- dep_xxf86vm = dependency('xxf86vm')
+ if with_glx_direct
+ dep_xxf86vm = dependency('xxf86vm')
+ endif
endif
endif
if (with_egl or
@@ -1847,7 +1849,9 @@ elif with_glx == 'dri'
'xcb-glx >= 1.8.1']
if with_dri_platform == 'drm'
gl_priv_reqs += 'xcb-dri2 >= 1.8'
- gl_priv_reqs += 'xxf86vm'
+ if with_glx_direct
+ gl_priv_reqs += 'xxf86vm'
+ endif
endif
endif
if dep_libdrm.found()