summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2020-09-01 22:09:43 +0200
committerMarge Bot <eric+marge@anholt.net>2020-09-04 09:07:16 +0000
commit0f4d09443eba0c5a219c943940ff970f3d583f56 (patch)
tree7c1498710441e602e1c7c0dd26967082d2d37855 /meson.build
parentebf2576862ca29b1173e3b7fee0cc03acbb4d7ef (diff)
meson: drop leftover PTHREAD_SETAFFINITY_IN_NP_HEADER
55765f80 replaced this with a check for the header itself. Fixes: 55765f80b9ce7cce4ec6 ("util/u_thread: include pthread_np.h if found") Signed-off-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Jonathan Gray <jsg@jsg.id.au> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6548>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index be007953c8b..fa178c435a9 100644
--- a/meson.build
+++ b/meson.build
@@ -1345,12 +1345,6 @@ if dep_thread.found() and host_machine.system() != 'windows'
args : '-D_GNU_SOURCE')
pre_args += '-DHAVE_PTHREAD_SETAFFINITY'
endif
- if cc.has_function(
- 'pthread_setaffinity_np',
- dependencies : dep_thread,
- prefix : '#include <pthread_np.h>')
- pre_args += '-DPTHREAD_SETAFFINITY_IN_NP_HEADER'
- endif
endif
if host_machine.system() != 'windows'
dep_expat = dependency('expat', fallback : ['expat', 'expat_dep'])