summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-03 17:06:22 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-10-09 13:42:44 -0700
commitc2cd5801cd1f05f8833a4c1c097b07757f763794 (patch)
tree1de4cd5831a3ff092511c30e11ff85d7bf1279c5 /meson.build
parent816bf7d1644b9b14df253c5d54f595514aa34703 (diff)
meson: build classic swrast
This adds support for building the classic swrast implementation. This driver has been tested with glxinfo and glxgears. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 79ee1a33459..bff40f697d3 100644
--- a/meson.build
+++ b/meson.build
@@ -73,10 +73,12 @@ endif
with_dri = false
with_dri_i965 = false
+with_dri_swrast = false
_drivers = get_option('dri-drivers')
if _drivers != ''
_split = _drivers.split(',')
with_dri_i965 = _split.contains('i965')
+ with_dri_swrast = _split.contains('swrast')
with_dri = true
endif