summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2010-05-20 11:00:01 +0200
committerJulien Cristau <jcristau@debian.org>2010-05-20 11:00:01 +0200
commit7a8e3614f700a4ca13f54b23d55355f93c6546f9 (patch)
tree1b42e7888492f4627b5c2e6b83fe880e0654b559 /debian
parent8d98d7832011d7ba490cbc18247508469ce21ddb (diff)
debian/rules: use DEB_HOST_ARCH_CPU instead of DEB_HOST_GNU_CPU.
Prompted by Ubuntu which changed the latter to i686, breaking their packages on i386.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules6
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e336418ff4e..891f299ccff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mesa (7.7.1-2) UNRELEASED; urgency=low
+
+ * debian/rules: use DEB_HOST_ARCH_CPU instead of DEB_HOST_GNU_CPU. Prompted
+ by Ubuntu which changed the latter to i686, breaking their packages on
+ i386.
+
+ -- Julien Cristau <jcristau@debian.org> Thu, 20 May 2010 10:59:05 +0200
+
mesa (7.7.1-1) unstable; urgency=low
[ Brice Goglin ]
diff --git a/debian/rules b/debian/rules
index 8a22ea898f6..b42d0b2539e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,7 +21,7 @@ DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
DEB_BUILD_DIR ?= $(CURDIR)/build
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build=$(DEB_HOST_GNU_TYPE)
@@ -70,9 +70,9 @@ else
DRI_DRIVERS += i915 i965
else ifneq ($(DEB_HOST_ARCH), s390)
DRI_DRIVERS += mach64 mga r128 r200 r300 r600 radeon savage tdfx
- ifeq ($(DEB_HOST_GNU_CPU), i486)
+ ifeq ($(DEB_HOST_ARCH_CPU), i386)
DRI_DRIVERS += i810 i915 i965 sis unichrome
- else ifeq ($(DEB_HOST_GNU_CPU), x86_64)
+ else ifeq ($(DEB_HOST_ARCH_CPU), amd64)
DRI_DRIVERS += i915 i965 sis unichrome
else ifeq ($(DEB_HOST_ARCH), sparc)
DRI_DRIVERS += ffb