summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-10-14 15:11:31 +0000
committerThierry Reding <thierry@gilfi.de>2006-10-14 15:11:31 +0000
commitd29244d8720c95f9e9869a51360902132b4b9c7e (patch)
tree4b1b849b6d33e65e5449c1fb417f3fcb3efc753a /debian/rules
parent0fca6eda1e9c0bc120eab95c3f79a504d9d3e316 (diff)
Add OSMesa configurations and made fixed several issues here and there.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 10 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 90e176e0b83..093efc14a90 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,10 +26,15 @@ DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
STAMPDIR = debian/stamp
+# build the following configurations
CONFIGS = debian \
- debian-dri
+ debian-dri \
+ debian-osmesa16 \
+ debian-osmesa16-static \
+ debian-osmesa32 \
+ debian-osmesa32-static
-STAMP = $(STAMPDIR)/$(DEB_BUILD_GNU_TYPE)-
+STAMP = $(STAMPDIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
@@ -42,14 +47,14 @@ $(STAMP)-build-%:
dh_testdir
mkdir -p $(DEB_BUILD_DIR)/$*
find $(CURDIR)/* -maxdepth 0 -not -path '$(DEB_BUILD_DIR)*' | xargs cp -rl -t $(DEB_BUILD_DIR)/$*
- ln -s $* $(DEB_BUILD_DIR)/$*/configs/current
+ ln -sf $* $(DEB_BUILD_DIR)/$*/configs/current
cd $(DEB_BUILD_DIR)/$* && $(MAKE)
touch $@
pre-install:
dh_testdir
dh_testroot
- dh_clean -k --exclude ./Makefile.orig
+ dh_clean -k --exclude ./Makefile.orig --exclude configs/CVS/Root.bak
dh_installdirs
install: build pre-install $(INSTALL_STAMPS)
@@ -62,7 +67,7 @@ clean:
dh_testdir
dh_testroot
rm -rf $(DEB_BUILD_DIR) debian/stamp
- dh_clean --exclude ./Makefile.orig
+ dh_clean --exclude ./Makefile.orig --exclude configs/CVS/Root.bak
# Build architecture-independent files here.
binary-indep: build install