summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-10-16 13:04:29 +0000
committerThierry Reding <thierry@gilfi.de>2006-10-16 13:04:29 +0000
commitc9db617e0b1764271e8a48450b356577132a82a3 (patch)
tree5448366e7f7dc086f23ad5f5e53562043936a9e7 /debian/rules
parentb43137d0cc450abca5083f6fcd110dcefab32b04 (diff)
Make the debian-static a subclass of debian-swx11+glu-default, because that's
what it actually is. Rename it accordingly and add it to SWX11_GLU_CONFIGS. Install the libOSMesa.so symlink and the libOSMesa static library in the libgl1-mesa-swx11-dev package. Add .shlibs files for the libgl1-mesa-swx11, libgl1-mesa-glx and libglu1-mesa packages.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ef8b0fa31f0..fbf328332e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -56,6 +56,9 @@ endif
# available for the build architecture. Use with caution =)
#SWX11_GLU_CONFIGS += $(subst configs/,,$(wildcard configs/debian-swx11+glu-$(DEB_BUILD_ARCH)-*))
+# build a static version of swx11 and GLU as well
+SWX11_GLU_CONFIGS += debian-swx11+glu-static
+
# choose an architecture-specific configuration for building the DRI-enabled
# libGL if one exists
ifneq ($(wildcard configs/debian-dri-$(DEB_BUILD_ARCH)),)
@@ -70,8 +73,7 @@ CONFIGS = $(SWX11_GLU_CONFIGS) \
debian-osmesa16 \
debian-osmesa16-static \
debian-osmesa32 \
- debian-osmesa32-static \
- debian-static
+ debian-osmesa32-static
STAMP = $(STAMP_DIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))