summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-10-20 07:56:11 +0000
committerThierry Reding <thierry@gilfi.de>2006-10-20 07:56:11 +0000
commitc7e576d6bfccc23aa4b6cfed97e97befda714d00 (patch)
tree33b0219e1631fe6c5a693d359b94a08158f6bb81 /debian/rules
parentf069b2812e16da4eadbbbd1b088f1b590879e690 (diff)
No longer install the default build of libOSMesa in the libgl1-mesa-swx11
package, but in the libosmesa6 package. Modify the 01_fix-makefile patch to not build libOSMesa on stand-alone builds, so that it is only created when building OSMesa explicitly. Build libOSMesa with 8 bits per color channel (the default) in dynamic and static versions separately from the software rasterization libGL with the software rasterization code linked in statically so that libOSMesa can run in parallel with any libGL. This should fix the problem Yann Dirson mentioned a while ago. Use the install-source.sh script to install the Mesa sources needed for the mesa-swx11-source package instead of doing it in the debian/rules file itself.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules33
1 files changed, 21 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index fbf328332e8..342cd1316e9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,10 +34,22 @@ else
SWX11_GLU_CONFIGS := debian-swx11+glu-any
endif
+# build a static version of swx11 and GLU as well
+SWX11_GLU_CONFIGS += debian-swx11+glu-static
+
+# choose an architecture-specific configuration for building the DRI-enabled
+# libGL if one exists
+ifneq ($(wildcard configs/debian-dri-$(DEB_BUILD_ARCH)),)
+ DRI_CONFIGS := debian-dri-$(DEB_BUILD_ARCH)
+else
+ DRI_CONFIGS := debian-dri-any
+endif
+
# additional configurations optimized for CPU's supported by the build
# architecture
ifeq ($(DEB_BUILD_ARCH), i386)
SWX11_GLU_CONFIGS += debian-swx11+glu-i386-i686
+# DRI_CONFIGS += debian-dri-i386-i686
endif
#ifeq ($(DEB_BUILD_ARCH), alpha)
@@ -56,20 +68,11 @@ endif
# available for the build architecture. Use with caution =)
#SWX11_GLU_CONFIGS += $(subst configs/,,$(wildcard configs/debian-swx11+glu-$(DEB_BUILD_ARCH)-*))
-# build a static version of swx11 and GLU as well
-SWX11_GLU_CONFIGS += debian-swx11+glu-static
-
-# choose an architecture-specific configuration for building the DRI-enabled
-# libGL if one exists
-ifneq ($(wildcard configs/debian-dri-$(DEB_BUILD_ARCH)),)
- DRI_CONFIGS := debian-dri-$(DEB_BUILD_ARCH)
-else
- DRI_CONFIGS := debian-dri-any
-endif
-
# build the following configurations by default
CONFIGS = $(SWX11_GLU_CONFIGS) \
$(DRI_CONFIGS) \
+ debian-osmesa \
+ debian-osmesa-static \
debian-osmesa16 \
debian-osmesa16-static \
debian-osmesa32 \
@@ -77,7 +80,8 @@ CONFIGS = $(SWX11_GLU_CONFIGS) \
STAMP = $(STAMP_DIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
-INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
+INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS)) \
+ $(STAMP_DIR)/install-source
# list the configurations that will built
configs:
@@ -114,6 +118,11 @@ $(STAMP)-install-%: $(STAMP)-build-%
cd $(DEB_BUILD_DIR)/$* && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
touch $@
+$(STAMP_DIR)/install-source:
+ # install Mesa source for mesa-swx11-source package
+ debian/scripts/install-source.sh
+ touch $@
+
clean: unpatch
dh_testdir
dh_testroot