summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-10-15 13:15:56 +0000
committerThierry Reding <thierry@gilfi.de>2006-10-15 13:15:56 +0000
commit8ef731bcd11af50e92fc1356532df44a80f7a4b0 (patch)
treea49e9e0b7ef5811b8671415f2a2dad6684fcc267 /debian/rules
parent8d02f3c68a1852de6bfe8c0b58c325224fef9743 (diff)
Add a patch (00_create-libdir) that fixes the upstream build system to make
sure the LIB_DIR is created or bail out. Update the 01_fix-makefile patch to only install libGL/libOSMesa if they exist. Don't make installation dependent on which drivers are built. Build optimized versions of the swx11 libraries in addition to those that should work on the least-capable supported processor for the given architecture. Have most configurations include debian-default instead of debian-common so that INSTALL_DIR is correctly defined. debian-common can probably be dropped anyway.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 966d25ed8b8..e2c8bbb941c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,14 +32,19 @@ STAMPDIR = debian/stamp
# build the following configurations
CONFIGS = debian \
+ debian-arch \
debian-dri \
- debian-osmesa \
debian-osmesa16 \
debian-osmesa16-static \
debian-osmesa32 \
debian-osmesa32-static \
debian-static
+# Don't build architecture-dependent DRI drivers (yet) because it's probably
+# not worth the effort. For benchmarking, include the following configuration
+# in the list above.
+#debian-dri-arch
+
STAMP = $(STAMPDIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
@@ -68,7 +73,7 @@ install: build pre-install $(INSTALL_STAMPS)
$(STAMP)-install-%: $(STAMP)-build-%
# Add here commands to install the package into debian/tmp
- cd $(DEB_BUILD_DIR)/$* && $(MAKE) install INSTALL_DIR=$(CURDIR)/debian/tmp/usr
+ cd $(DEB_BUILD_DIR)/$* && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
touch $@
clean: unpatch