summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-11-10 09:00:00 +0000
committerThierry Reding <thierry@gilfi.de>2006-11-10 09:00:00 +0000
commit50faa32ce32fe5f7409705bffb73efceb0b20354 (patch)
tree7cd549f1a099cd94d841cd7397a80aa6e2191611 /debian/rules
parentb6caed527ccdcce15cfdf31aa77813e52c0faab4 (diff)
Move the code to choose which configurations to build to a separate script in
order to keep debian/rules cleaner.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules43
1 files changed, 4 insertions, 39 deletions
diff --git a/debian/rules b/debian/rules
index 307088a54de..7d3196ff7dc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,46 +26,11 @@ DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
export DEB_BUILD_ARCH
-# choose an architecture-specific build of swx11 and GLU if a matching
-# configuration exists
-ifneq ($(wildcard configs/debian-swx11+glu-$(DEB_BUILD_ARCH)),)
- SWX11_GLU_CONFIGS := debian-swx11+glu-$(DEB_BUILD_ARCH)
-else
- SWX11_GLU_CONFIGS := debian-swx11+glu-any
-endif
-
-# same for static builds
-ifneq ($(wildcard configs/debian-swx11+glu-static-$(DEB_BUILD_ARCH)),)
- SWX11_GLU_CONFIGS += debian-swx11+glu-static-$(DEB_BUILD_ARCH)
-else
- SWX11_GLU_CONFIGS += debian-swx11+glu-static-any
-endif
-
-# and for the GLX/DRI-enabled libGL
-ifneq ($(wildcard configs/debian-dri-$(DEB_BUILD_ARCH)),)
- DRI_CONFIGS := debian-dri-$(DEB_BUILD_ARCH)
-else
- DRI_CONFIGS := debian-dri-any
-endif
-
-# additional configurations optimized for CPU's supported by the build
-# architecture
-ifeq ($(DEB_BUILD_ARCH), i386)
- SWX11_GLU_CONFIGS += debian-swx11+glu-i386-i686
-# DRI_CONFIGS += debian-dri-i386-i686
-endif
-
-#ifeq ($(DEB_BUILD_ARCH), alpha)
-# SWX11_GLU_CONFIGS += debian-swx11+glu-alpha-ev5
-#endif
-
-#ifeq ($(DEB_BUILD_ARCH), powerpc)
-# SWX11_GLU_CONFIGS += debian-swx11+glu-powerpc-603
-#endif
+# choose which configurations to build
+SWX11_GLU_CONFIGS =
+DRI_CONFIGS =
-#ifeq ($(DEB_BUILD_ARCH), sparc)
-# SWX11_GLU_CONFIGS += debian-swx11+glu-sparc-ultrasparc
-#endif
+include debian/scripts/choose-configs
# build the following configurations by default
CONFIGS = $(SWX11_GLU_CONFIGS) \