summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-10-14 04:33:41 +0000
committerThierry Reding <thierry@gilfi.de>2006-10-14 04:33:41 +0000
commit0fca6eda1e9c0bc120eab95c3f79a504d9d3e316 (patch)
treee558e8906e4d1c4ed248bb915e202bdfdca21e81 /debian/rules
parent1ddf606332a188e46a47607cd41eb5d81bdf4c8a (diff)
Initial version of a new build system for Mesa.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules93
1 files changed, 93 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000000..90e176e0b83
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,93 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS = -Wall -g
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
+
+STAMPDIR = debian/stamp
+
+CONFIGS = debian \
+ debian-dri
+
+STAMP = $(STAMPDIR)/$(DEB_BUILD_GNU_TYPE)-
+BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
+INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
+
+debian/stamp:
+ dh_testdir
+ mkdir -p debian/stamp
+
+build: debian/stamp $(BUILD_STAMPS)
+$(STAMP)-build-%:
+ dh_testdir
+ mkdir -p $(DEB_BUILD_DIR)/$*
+ find $(CURDIR)/* -maxdepth 0 -not -path '$(DEB_BUILD_DIR)*' | xargs cp -rl -t $(DEB_BUILD_DIR)/$*
+ ln -s $* $(DEB_BUILD_DIR)/$*/configs/current
+ cd $(DEB_BUILD_DIR)/$* && $(MAKE)
+ touch $@
+
+pre-install:
+ dh_testdir
+ dh_testroot
+ dh_clean -k --exclude ./Makefile.orig
+ dh_installdirs
+
+install: build pre-install $(INSTALL_STAMPS)
+
+$(STAMP)-install-%:
+ # Add here commands to install the package into debian/tmp
+ cd $(DEB_BUILD_DIR)/$* && $(MAKE) install INSTALL_DIR=$(CURDIR)/debian/tmp/usr
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -rf $(DEB_BUILD_DIR) debian/stamp
+ dh_clean --exclude ./Makefile.orig
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp --list-missing
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
+