summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <thierry@gilfi.de>2006-10-15 13:30:22 +0000
committerThierry Reding <thierry@gilfi.de>2006-10-15 13:30:22 +0000
commit5bcfa4c85908474774b8537f379504fb8ad9a598 (patch)
tree201619deabf15f3efc6d149cc82a2ae014a7ae3c /debian/rules
parent8ef731bcd11af50e92fc1356532df44a80f7a4b0 (diff)
Build only optimized versions of the DRI drivers, only using no optimizations
when not supported. Add configuration to build the DRI drivers on amd64.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 1 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index e2c8bbb941c..269e724bcee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,18 +33,13 @@ STAMPDIR = debian/stamp
# build the following configurations
CONFIGS = debian \
debian-arch \
- debian-dri \
+ debian-dri-arch \
debian-osmesa16 \
debian-osmesa16-static \
debian-osmesa32 \
debian-osmesa32-static \
debian-static
-# Don't build architecture-dependent DRI drivers (yet) because it's probably
-# not worth the effort. For benchmarking, include the following configuration
-# in the list above.
-#debian-dri-arch
-
STAMP = $(STAMPDIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))