summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakob Bornecrantz <jakob@vmware.com>2009-11-12 01:28:26 +0100
committerJakob Bornecrantz <jakob@vmware.com>2009-11-17 03:18:06 +0100
commit60769b232c8eedddc24f25ab91f35bcb6973dded (patch)
tree1087b93667e0f4b787780a44ab32eeb5028ab4bf /configure.ac
parentf7109aaf6c6020da89a0683cf5548181f2db36fb (diff)
svga: Build svga driver
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc588d5fabd..f9476a46dda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,6 +1190,19 @@ AC_ARG_WITH([max-height],
)
dnl
+dnl Gallium SVGA configuration
+dnl
+AC_ARG_ENABLE([gallium-svga],
+ [AS_HELP_STRING([--disable-gallium-svga],
+ [build gallium SVGA @<:@default=enabled@:>@])],
+ [enable_gallium_svga="$enableval"],
+ [enable_gallium_svga=yes])
+if test "x$enable_gallium_svga" = xyes; then
+ GALLIUM_WINSYS_DRM_DIRS="$GALLIUM_WINSYS_DRM_DIRS vmware"
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga"
+fi
+
+dnl
dnl Gallium Intel configuration
dnl
AC_ARG_ENABLE([gallium-intel],