summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakob Bornecrantz <jakob@vmware.com>2009-07-19 09:22:31 +0200
committerJakob Bornecrantz <jakob@vmware.com>2009-07-19 09:29:14 +0200
commit5e6fff7ac4a4e0d06d394391f6e2dd2eb6ff8aee (patch)
treee342f91c49b69fa27ab417d6ee9b79444ee2a087 /configure.ac
parentbf75ee9ccc6bb00ee0251997afcb522ead68f170 (diff)
svga: Do the gallium intel configure trick for svga as well
Since the drivers we produce on systems where we use configure depend on none stable kernel API the driver deliverables should not be built by default in the mesa 7.7 release. People wishing to shoot them self in the foot have to pull the trigger themself, we just hand them the gun.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 25e4321510f..e15e1f60c44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1200,13 +1200,15 @@ dnl
dnl Gallium SVGA configuration
dnl
AC_ARG_ENABLE([gallium-svga],
- [AS_HELP_STRING([--disable-gallium-svga],
- [build gallium SVGA @<:@default=enabled@:>@])],
+ [AS_HELP_STRING([--enable-gallium-svga],
+ [build gallium SVGA @<:@default=disabled@:>@])],
[enable_gallium_svga="$enableval"],
- [enable_gallium_svga=yes])
+ [enable_gallium_svga=auto])
if test "x$enable_gallium_svga" = xyes; then
GALLIUM_WINSYS_DRM_DIRS="$GALLIUM_WINSYS_DRM_DIRS vmware"
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga"
+elif test "x$enable_gallium_svga" = xauto; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga"
fi
dnl