summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinson Lee <vlee@freedesktop.org>2012-10-11 18:19:49 -0700
committerVinson Lee <vlee@freedesktop.org>2012-10-16 23:28:22 -0700
commit53e36d333c9b619c1a5fe9a8d2d08665654b0234 (patch)
treea85e7f10d9b35ab7fead787590fdd9f70e385a91 /configure.ac
parent0199ff7fe323cf527ffacfdef3258ab85799dd13 (diff)
build: Build on Cygwin with gnu99 instead of c99.
The GCC c99 standard on Cygwin sets __STRICT_ANSI__ and symbols such as strdup are not available. Signed-off-by: Vinson Lee <vlee@freedesktop.org> Reviewed-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index aa72523c0a5..6f851e25c1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,7 +172,14 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -Wall -std=c99"
+ case "$host_os" in
+ cygwin*)
+ CFLAGS="$CFLAGS -Wall -std=gnu99"
+ ;;
+ *)
+ CFLAGS="$CFLAGS -Wall -std=c99"
+ ;;
+ esac
# Enable -Werror=implicit-function-declaration and
# -Werror=missing-prototypes, if available, or otherwise, just