summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-26 10:50:04 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-26 11:49:47 +0100
commit412042523e80ddb19196851b6e729238b5cc0609 (patch)
tree5987ad1cf1d3838d7c54be19ab57370df7460571 /configure.ac
parentb6d3a435a0e0e53a9e8cc4c4249dc7c2f897a83d (diff)
configure: Use WAYLAND_SCANNER_RULES only if available
This has the drawback that when creating configure for distribution, wayland needs to be available for the packager. Also the the macros has the wayland prefix hardcoded, so we cant copy it in mesa right now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 59919f085fc..c9e658c69a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1710,7 +1710,8 @@ yes)
[AC_MSG_ERROR([cannot find libwayland-client])])
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/wayland"
- WAYLAND_SCANNER_RULES(['$(top_srcdir)/src/egl/wayland/wayland-drm/protocol'])
+ m4_ifdef([WAYLAND_SCANNER_RULES],
+ [WAYLAND_SCANNER_RULES(['$(top_srcdir)/src/egl/wayland/wayland-drm/protocol'])])
fi
if test "$plat" = "drm" && test "x$enable_gbm" = "xno"; then
AC_MSG_ERROR([EGL platform drm needs gbm])