summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2012-10-10 22:10:42 -0400
committerKristian Høgsberg <krh@bitplanet.net>2012-10-17 16:32:13 -0400
commit0229e3ae41be109ac423b2eb2ddf79e24b799d60 (patch)
tree5423c0a5e6a5a4c7559b03de3a84d230e6008451 /configure.ac
parentbe4c0a243e3314b8d8d24107494e2537a6d198ad (diff)
egl/wayland: Update to Wayland 0.99 API
The 0.99.0 Wayland release changes the event API to provide a thread-safe mechanism for receiving events specific to a subsystem (such as EGL) and we need to use it in the EGL platform. The Wayland protocol now also requires a commit request to make changes take effect, issue that from eglSwapBuffers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6f851e25c1c..aefa14229e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1505,7 +1505,7 @@ for plat in $egl_platforms; do
;;
wayland)
- PKG_CHECK_MODULES([WAYLAND], [wayland-client wayland-server],, \
+ PKG_CHECK_MODULES([WAYLAND], [wayland-client >= 0.99.0 wayland-server >= 0.99.0],, \
[AC_MSG_ERROR([cannot find libwayland-client])])
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/wayland"