summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-06-07 10:08:48 -0400
committerKristian Høgsberg <krh@bitplanet.net>2010-06-07 10:08:48 -0400
commit56c3cce2a199f7f79a48d7633431e1e80fcd4ba2 (patch)
tree317af8c00e8758c8a11437b694174db461eb5fb3 /configure.ac
parentb4483823d9c1205fb9ab8cf5b4c36ee610347a36 (diff)
Remove last bits of progs/ infrastructure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index c4a4f955fe8..6fc0e2a55c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -503,40 +503,6 @@ AC_SUBST([GALLIUM_STATE_TRACKERS_DIRS])
AC_SUBST([MESA_LLVM])
dnl
-dnl User supplied program configuration
-dnl
-if test -d "$srcdir/progs/demos"; then
- default_demos=yes
-else
- default_demos=no
-fi
-AC_ARG_WITH([demos],
- [AS_HELP_STRING([--with-demos@<:@=DIRS...@:>@],
- [optional comma delimited demo directories to build
- @<:@default=auto if source available@:>@])],
- [with_demos="$withval"],
- [with_demos="$default_demos"])
-if test "x$with_demos" = x; then
- with_demos=no
-fi
-
-dnl If $with_demos is yes, directories will be added as libs available
-PROGRAM_DIRS=""
-case "$with_demos" in
-no) ;;
-yes) ;;
-*)
- # verify the requested demos directories exist
- demos=`IFS=,; echo $with_demos`
- for demo in $demos; do
- test -d "$srcdir/progs/$demo" || \
- AC_MSG_ERROR([Program directory '$demo' doesn't exist])
- done
- PROGRAM_DIRS="$demos"
- ;;
-esac
-
-dnl
dnl Find out if X is available. The variable have_x is set if libX11 is
dnl found to mimic AC_PATH_XTRA.
dnl
@@ -1014,10 +980,6 @@ if test "x$enable_egl" = xyes; then
EGL_DRIVERS_DIRS="$EGL_DRIVERS_DIRS dri2"
fi
fi
-
- if test "$with_demos" = yes; then
- PROGRAM_DIRS="$PROGRAM_DIRS egl/eglut"
- fi
fi
AC_SUBST([EGL_LIB_DEPS])
AC_SUBST([EGL_DRIVERS_DIRS])
@@ -1634,15 +1596,6 @@ echo " GLU: $enable_glu"
echo " GLw: $enable_glw (Motif: $enable_motif)"
echo " glut: $enable_glut"
-dnl Programs
-# cleanup the programs var for display
-program_dirs=`echo $PROGRAM_DIRS | $SED 's/^ *//;s/ */ /;s/ *$//'`
-if test "x$program_dirs" = x; then
- echo " Demos: no"
-else
- echo " Demos: $program_dirs"
-fi
-
dnl Compiler options
# cleanup the CFLAGS/CXXFLAGS/DEFINES vars
cflags=`echo $CFLAGS $OPT_FLAGS $PIC_FLAGS $ARCH_FLAGS | \