summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-07-16 20:09:29 +0800
committerChia-I Wu <olv@lunarg.com>2010-07-16 20:19:13 +0800
commit08f4bc07e424aaeb35eb58736fdca64b1398c190 (patch)
tree4944450e7e9efa97ce751e80b7be9dc216e86dfc /configure.ac
parent39ae965783d43ecc4426d0340381c091518bdedb (diff)
st/egl: Fix build on FreeBSD.
There is no libdl on FreeBSD. Based on patch from Thinker <thinker@branda.to>, which is against 7.8. This fixes fdo bug #29093.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1214100a8fd..96195976a0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -410,6 +410,7 @@ dnl Check to see if dlopen is in default libraries (like Solaris, which
dnl has it in libc), or if libdl is needed to get it.
AC_CHECK_FUNC([dlopen], [],
[AC_CHECK_LIB([dl], [dlopen], [DLOPEN_LIBS="-ldl"])])
+AC_SUBST([DLOPEN_LIBS])
dnl See if posix_memalign is available
AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])