summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornobled <nobled@dreamwidth.org>2011-03-14 22:08:22 +0000
committerJon TURNEY <jon.turney@dronecode.org.uk>2011-04-08 20:37:38 +0100
commite7d18ed1ef8106e2f0eec1078efde6da358e692b (patch)
tree5d0912d7c2bc46819ae07c4bcf2e72e7ec2a2f03 /configure.ac
parent758561786c3a34303e6c85dfdb996b94a4eed678 (diff)
Disable direct rendering on GNU/Hurd
The Hurd kernel doesn't have DRM yet. Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Julien Cristau <jcristau@debian.org> Reviewed-By: Jakob Bornecrantz <wallbraker@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 38e673da8a1..5bcb5a11a2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -730,12 +730,21 @@ else
fi
dnl Direct rendering or just indirect rendering
+case "$host_os" in
+gnu*)
+ dnl Disable by default on GNU/Hurd
+ driglx_direct_default="no"
+ ;;
+*)
+ driglx_direct_default="yes"
+ ;;
+esac
AC_ARG_ENABLE([driglx-direct],
[AS_HELP_STRING([--disable-driglx-direct],
[enable direct rendering in GLX and EGL for DRI \
- @<:@default=enabled@:>@])],
+ @<:@default=auto@:>@])],
[driglx_direct="$enableval"],
- [driglx_direct="yes"])
+ [driglx_direct="$driglx_direct_default"])
dnl
dnl libGL configuration per driver