summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-07-02 13:46:42 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-07-12 09:58:11 +0200
commitb0549fab5c31a12d46b2bd833ce7d8d3f7b8f911 (patch)
treebbf16d846945e89a0872f37be350240a5cf63035 /configure.ac
parentac8891697842922b755c0e4724a2035fef161254 (diff)
configure: Require libudev for drm & wayland egl platforms
NOTE: This is a candidate for the 7.11 branch. (cherry picked from commit 7ed1826e2e2a5b5c4840821c92ef7273efe32e24)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a41e801f70b..085e328c92f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1661,6 +1661,10 @@ yes)
if test "$plat" = "drm" && test "x$enable_gbm" = "xno"; then
AC_MSG_ERROR([EGL platform drm needs gbm])
fi
+ case "$plat$have_libudev" in
+ waylandno|drmno)
+ AC_MSG_ERROR([cannot build $plat platfrom without udev]) ;;
+ esac
done
EGL_PLATFORMS="$egl_platforms"
;;