summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuan A. Suarez Romero <jasuarez@igalia.com>2018-08-06 11:30:08 +0200
committerJuan A. Suarez Romero <jasuarez@igalia.com>2018-08-20 16:13:37 +0200
commit0cef0cccf51fc20d797edef458a09af73108260c (patch)
treee8b12158510a7187a1bf675db42191008742aec6 /configure.ac
parent25ec806eb249603ad0364365ab620628cf25f031 (diff)
swr: bump minimum supported LLVM version to 6.0
RADV now requires LLVM 6.0 or greater, and thus we can't build dist tarball because swr requires LLVM 5.0. Let's bump required LLVM to 6.0 in swr too. v2: bump also in meson.build (Eric) Fixes: fd1121e839 ("amd: remove support for LLVM 5.0") Cc: Tim Rowley <timothy.o.rowley@intel.com> Cc: Emil Velikov <emil.velikov@collabora.com> Cc: Dylan Baker <dylan@pnwbakers.com> Cc: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Bruce Cherniak <bruce.cherniak@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2f1d13ce6ef..4d9d9e59280 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,7 @@ LLVM_REQUIRED_OPENCL=3.9.0
LLVM_REQUIRED_R600=3.9.0
LLVM_REQUIRED_RADEONSI=6.0.0
LLVM_REQUIRED_RADV=6.0.0
-LLVM_REQUIRED_SWR=5.0.0
+LLVM_REQUIRED_SWR=6.0.0
dnl Check for progs
AC_PROG_CPP
@@ -2816,9 +2816,8 @@ if test -n "$with_gallium_drivers"; then
fi
# XXX: Keep in sync with LLVM_REQUIRED_SWR
-AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x5.0.0 -a \
- "x$LLVM_VERSION" != x5.0.1 -a \
- "x$LLVM_VERSION" != x5.0.2)
+AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x6.0.0 -a \
+ "x$LLVM_VERSION" != x6.0.1)
if test "x$enable_llvm" = "xyes" -a "$with_gallium_drivers"; then
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"