summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-02-22 16:47:21 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2014-02-24 14:57:41 +0000
commit61973ffe5b3b676472bab29b1f556278ecce8cbf (patch)
treeea6ecdf84b5b002e25e21117610294ac5a107661 /configure.ac
parent3445e8bb921545f74e2b6a823d47fa29352e9262 (diff)
configure: correctly report if we're building the sw/xlib winsys
While looking at bug 75356, I've noticed that the presence of x11 egl platform pulls in sw/xlib as "needed" but fails to report so at the end of configure. Tested-by: Tom Stellard <thomas.stellard@amd.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d42803c8a45..24ffc545b78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1448,6 +1448,7 @@ else
fi
if echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1; then
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib"
NEED_WINSYS_XLIB=yes
fi
AM_CONDITIONAL(HAVE_EGL_PLATFORM_X11, echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1)