summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2014-01-23 13:12:26 -0800
committerEric Anholt <eric@anholt.net>2014-01-27 09:36:24 -0800
commit4556c734700da2dd95d4f148d6929a537882bade (patch)
tree869f9ffc7cb84e4f69017837d91bc5f61c7df626 /configure.ac
parentd51dbe048afd2131eb3675e9cd868ce73325a61d (diff)
loader: Use dlsym to get our udev symbols instead of explicit linking.
Steam links against libudev.so.0, while we're linking against libudev.so.1. The result is that the symbol names (which are the same in the two libraries) end up conflicting, and some of the usage of .so.1 calls the .so.0 bits, which have different internal structures, and segfaults happen. By using a dlopen() with RTLD_LOCAL, we can explicitly look for the symbols we want, while they get the symbols they want. Reviewed-by: Keith Packard <keithp@keithp.com> Reviewed-by: Kristian Høgsberg <krh@bitplanet.net> Tested-by: Alexandre Demers <alexandre.f.demers@gmail.com> Tested-by: Mike Lothian <mike@fireburn.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 33ac9225948..d266d96b674 100644
--- a/configure.ac
+++ b/configure.ac
@@ -858,7 +858,7 @@ xyesno)
if test x"$enable_dri3$have_libudev" = xyesyes; then
X11_INCLUDES="$X11_INCLUDES $LIBUDEV_CFLAGS"
- GL_LIB_DEPS="$GL_LIB_DEPS $LIBUDEV_LIBS"
+ GL_LIB_DEPS="$GL_LIB_DEPS"
fi
# need DRM libs, $PTHREAD_LIBS, etc.