summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosé Fonseca <jfonseca@vmware.com>2014-03-24 15:41:08 +0000
committerJosé Fonseca <jfonseca@vmware.com>2014-03-26 13:51:32 +0000
commit2de70fe23f320ce4f559e37057fe07b7af99cf5a (patch)
tree16806aa819e81b03cb4be45144f99d6e29ae1cd8 /configure.ac
parentb761dfa0c3de4bc69a5b8bdf6cb9f6993ad7173d (diff)
mapi/glapi: Use ElementTree instead of libxml2.
It is quite hard to meet the dependency of the libxml2 python bindings outside Linux, and in particularly on MacOSX; whereas ElementTree is part of Python's standard library. ElementTree is more limited than libxml2: no DTD verification, defaults from DTD, or XInclude support, but none of these limitations is serious enough to justify using libxml2. In fact, it was easier to refactor the code to use ElementTree than to try to get libxml2 python bindings. In the process, gl_item_factory class was refactored so that there is one method for each kind of object to be created, as it simplifies things substantially. I confirmed that precisely the same output is generated for GL/GLX/GLES. v2: Remove m4/ax_python_module.m4 as suggested by Matt Turner. Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 97d7dc5eaf1..1e5e49667cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,6 @@ AM_PROG_CC_C_O
AM_PROG_AS
AC_CHECK_PROGS([MAKE], [gmake make])
AC_CHECK_PROGS([PYTHON2], [python2 python])
-AX_PYTHON_MODULE([libxml2], [needed])
AC_PROG_SED
AC_PROG_MKDIR_P