summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-02-27 18:03:15 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2014-03-04 02:13:14 +0000
commit1bb23abe0659559ec95d6d20cdcfc67b48619286 (patch)
tree7448aff56667623f61396bd27d8670d307d33d21 /configure.ac
parent1e3bdb35a686bbc9665c610c942ec2c1353f2ebc (diff)
configure: disable shared glapi when building xlib powered glx
With commit 0432aa064b(configure: use shared-glapi when more than one gl* API is used) we removed "disable shared-glapi when building without dri" hunk. In the good old days of classic mesa, dri and xlib-glx were mutually exclusive thus the hunk made sense. Currently enable-dri is used as a synonym for a range of things thus it's more appropriate to handle xlib-glx explicitly. Fixes a missing symbol '_glapi_Dispatch' in a xlib powered libGL, build using the following ./autogen.sh --enable-xlib-glx --disable-dri --with-gallium-drivers=swrast Cc: Brian Paul <brianp@vmware.com> Reported-by: Brian Paul <brianp@vmware.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf288c51bea..1bd02c4a7eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -753,6 +753,12 @@ x*yes*yes*)
;;
esac
+# Building Xlib-GLX requires shared glapi to be disabled.
+if test "x$enable_xlib_glx" = xyes; then
+ AC_MSG_NOTICE([Shared GLAPI should not used with Xlib-GLX, disabling])
+ enable_shared_glapi=no
+fi
+
AM_CONDITIONAL(HAVE_SHARED_GLAPI, test "x$enable_shared_glapi" = xyes)
dnl