summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-02-19 00:54:04 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2014-02-21 22:48:50 +0000
commit0432aa064bf5d4d0ad8fc3c4d648b8feb238ddfa (patch)
treed58d5d26337d9b005c42729576357f7477f962d3 /configure.ac
parent9eae750317b52d05448ec327ec7499908a4653cf (diff)
configure: use shared-glapi when more than one gl* API is used
Current behaviour states that shared-glapi is usefull when building with dri, which is not the case. Shared-glapi is used to dispatch the gl* functions across the one or more gl api's which can be dri based but do not need to be. Fixed the following build ./configure --enable-gles2 --disable-dri --enable-gallium-egl \ --with-egl-platforms=fbdev --with-gallium-drivers=swrast Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75098 Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ed7f6b7fb5e..08aed4e30c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -727,13 +727,16 @@ AC_ARG_ENABLE([shared-glapi],
[AS_HELP_STRING([--enable-shared-glapi],
[Enable shared glapi for OpenGL @<:@default=yes@:>@])],
[enable_shared_glapi="$enableval"],
- [enable_shared_glapi="$enable_dri"])
+ [enable_shared_glapi=yes])
-# Shared GLAPI is only useful for DRI
-if test "x$enable_dri" = xno; then
- AC_MSG_NOTICE([Shared GLAPI is only useful for DRI, disabling])
- enable_shared_glapi=no
-fi
+case "x$enable_opengl$enable_gles1$enable_gles2" in
+x*yes*yes*)
+ if test "x$enable_shared_glapi" = xno; then
+ AC_MSG_ERROR([shared GLAPI required when building two or more of
+ the following APIs - opengl, gles1 gles2])
+ fi
+ ;;
+esac
AM_CONDITIONAL(HAVE_SHARED_GLAPI, test "x$enable_shared_glapi" = xyes)