summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <jsg@jsg.id.au>2013-06-20 20:14:33 +1000
committerVinson Lee <vlee@freedesktop.org>2013-07-17 22:50:19 -0700
commitf96c07abf6ded1ac07a1e8fe3952321ec170193d (patch)
tree315d28123be95ae0d639e01999529a22a952fdda /configure.ac
parent78fbb41fe3c2301021b8fd60dabc26d1cf62fdfc (diff)
configure.ac: make grep tests more portable
Use grep -w instead of the empty string escape sequences which are less portable. Makes the grep tests function as intended on OpenBSD. Signed-off-by: Jonathan Gray <jsg@jsg.id.au> Reviewed-by: Vinson Lee <vlee@freedesktop.org> Signed-off-by: Vinson Lee <vlee@freedesktop.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 100f75f08b5..3ddcef7c6e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1605,14 +1605,14 @@ if test "x$enable_gallium_llvm" = xyes; then
fi
LLVM_COMPONENTS="engine bitwriter"
- if $LLVM_CONFIG --components | grep -q '\<mcjit\>'; then
+ if $LLVM_CONFIG --components | grep -qw 'mcjit'; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} mcjit"
fi
if test "x$enable_opencl" = xyes; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} ipo linker instrumentation"
# LLVM 3.3 >= 177971 requires IRReader
- if $LLVM_CONFIG --components | grep -q '\<irreader\>'; then
+ if $LLVM_CONFIG --components | grep -qw 'irreader'; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} irreader"
fi
fi
@@ -1727,7 +1727,7 @@ radeon_llvm_check() {
if test "$LLVM_VERSION_INT" -lt "${LLVM_REQUIRED_VERSION_MAJOR}0${LLVM_REQUIRED_VERSION_MINOR}"; then
AC_MSG_ERROR([LLVM $LLVM_REQUIRED_VERSION_MAJOR.$LLVM_REQUIRED_VERSION_MINOR or newer is required for r600g and radeonsi.])
fi
- if test true && $LLVM_CONFIG --targets-built | grep -qv '\<R600\>' ; then
+ if test true && $LLVM_CONFIG --targets-built | grep -qvw 'R600' ; then
AC_MSG_ERROR([LLVM R600 Target not enabled. You can enable it when building the LLVM
sources with the --enable-experimental-targets=R600
configure flag])