summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-01-14 16:16:00 -0800
committerMatt Turner <mattst88@gmail.com>2013-01-22 14:33:16 -0800
commitcc9f609cb9175e727b91f8dffa5800818be582da (patch)
treeb85088c889522f1a914f5fd55c24fa3c091248d1 /configure.ac
parent569f0e400aca0e7bfd13374384fb8d92caf869bc (diff)
glsl/build: Don't build builtin_compiler separately if not cross compiling
Reduces the number of times that src/glsl/ is compiled when not cross compiling. Tested-by: Andreas Boll <andreas.boll.dev@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7c234016db..264e9c7cbd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1967,6 +1967,8 @@ AM_CONDITIONAL(HAVE_X86_ASM, echo "$DEFINES" | grep 'X86_ASM' >/dev/null 2>&1)
AM_CONDITIONAL(HAVE_X86_64_ASM, echo "$DEFINES" | grep 'X86_64_ASM' >/dev/null 2>&1)
AM_CONDITIONAL(HAVE_SPARC_ASM, echo "$DEFINES" | grep 'SPARC_ASM' >/dev/null 2>&1)
+AM_CONDITIONAL(CROSS_COMPILING, test "x$cross_compiling" = xyes)
+
AC_SUBST([VDPAU_MAJOR], 1)
AC_SUBST([VDPAU_MINOR], 0)