summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-04-17 13:29:41 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-04-17 13:37:41 +0100
commit7748c3f5eb1d98ca97d2cf6e516ff54a5d75130a (patch)
tree35358d27a410a534e77526c2227a5a5fed918c11 /configure.ac
parentde128c19eef5a4a04fadc2ad519f2e6a515ea7b5 (diff)
configure.ac: deprecate --with-egl-platforms over --with-platforms17.1-branchpoint
Currently the former controls more than just EGL. With follow-up commits we'll unwind and fix things so that one can build the different drivers with said platform support. Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 28 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4b11273146f..2dd5cf014b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2142,14 +2142,17 @@ dnl
AM_CONDITIONAL(HAVE_GALLIUM, test -n "$with_gallium_drivers")
dnl
-dnl EGL Platforms configuration
+dnl DEPRECATED: EGL Platforms configuration
dnl
AC_ARG_WITH([egl-platforms],
[AS_HELP_STRING([--with-egl-platforms@<:@=DIRS...@:>@],
- [comma delimited native platforms libEGL supports, e.g.
- "x11,drm" @<:@default=auto@:>@])],
+ [DEPRECATED: use --with-plaforms instead@<:@default=auto@:>@])],
[with_egl_platforms="$withval"],
- [if test "x$enable_egl" = xyes; then
+ [with_egl_platforms=auto])
+
+if test "x$with_egl_platforms" = xauto; then
+ AC_MSG_WARN([--with-egl-platforms is deprecated. Use --with-plaforms instead.])
+ if test "x$enable_egl" = xyes; then
if test "x$enable_gbm" = xyes; then
with_egl_platforms="x11,drm"
else
@@ -2157,7 +2160,23 @@ AC_ARG_WITH([egl-platforms],
fi
else
with_egl_platforms=""
- fi])
+ fi
+fi
+
+dnl
+dnl Platforms configuration
+dnl
+AC_ARG_WITH([platforms],
+ [AS_HELP_STRING([--with-platforms@<:@=DIRS...@:>@],
+ [comma delimited native platforms libEGL/Vulkan/other supports, e.g.
+ "x11,drm,wayland,surfaceless..." @<:@default=auto@:>@])],
+ [with_platforms="$withval"],
+ [with_platforms=auto])
+
+# For the time being, we still reuse the EGL named variables/defines.
+if test "x$with_platforms" != xauto; then
+ with_egl_platforms=$with_platforms
+fi
PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
@@ -2302,8 +2321,8 @@ require_basic_egl() {
;;
*)
AC_MSG_ERROR([$1 requires one of these:
- 1) --with-egl-platforms=drm (X, Wayland, offscreen rendering based on DRM)
- 2) --with-egl-platforms=surfaceless (offscreen only)
+ 1) --with-platforms=drm (X, Wayland, offscreen rendering based on DRM)
+ 2) --with-platforms=surfaceless (offscreen only)
Recommended options: drm,x11])
;;
esac
@@ -2833,7 +2852,6 @@ dnl EGL
echo ""
echo " EGL: $enable_egl"
if test "$enable_egl" = yes; then
- echo " EGL platforms: $egl_platforms"
egl_drivers=""
if test "x$enable_dri" != "xno"; then
@@ -2851,6 +2869,8 @@ else
echo " GBM: no"
fi
+ echo " EGL/Vulkan/VL platforms: $egl_platforms"
+
# Vulkan
echo ""
if test "x$VULKAN_DRIVERS" != x; then