summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-05-04 11:47:14 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2016-05-23 12:07:47 +0100
commit2cd687ce97f39bd98fab4d72d607b7a1644cd2a0 (patch)
tree87270b3a429aeccb7aa1b4a14332067c0b87b66f /configure.ac
parenta155cdaace09e5fd2712528a6fa28ca3818d41a3 (diff)
configure.ac: error out when building from git without python3
Bail early, as opposed to later on during the build. Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3499e99f5e4..070bae20dc2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,12 @@ else
fi
fi
+if test -z "$PYTHON3"; then
+ if test ! -f "$srcdir/src/intel/genxml/gen9_pack.h"; then
+ AC_MSG_ERROR([Python3 not found - unable to generate sources])
+ fi
+fi
+
AC_PROG_INSTALL
dnl We need a POSIX shell for parts of the build. Assume we have one