summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2016-03-24 17:30:14 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2016-03-24 17:30:14 -0700
commit2c3f95d6aaab38cd66dd3dee1b089d5c91928eea (patch)
tree43423daf0da9c45f4054c5763a87f33dbfc7c4d5 /configure.ac
parenta5dc3c0f02aa523d1d3d123b62b9a187821079fe (diff)
parent22b343a8ec75a08dae6a6badbb261eab8437475d (diff)
Merge remote-tracking branch 'public/master' into vulkan
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 5 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 384de4dbde6..6fe060ccb49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -704,8 +704,10 @@ test "x$enable_asm" = xno && AC_MSG_RESULT([no])
if test "x$enable_asm" = xyes -a "x$cross_compiling" = xyes; then
case "$host_cpu" in
i?86 | x86_64 | amd64)
- enable_asm=no
- AC_MSG_RESULT([no, cross compiling])
+ if test "x$host_cpu" != "x$target_cpu"; then
+ enable_asm=no
+ AC_MSG_RESULT([no, cross compiling])
+ fi
;;
esac
fi
@@ -929,12 +931,6 @@ AC_ARG_ENABLE([xlib-glx],
[enable_xlib_glx="$enableval"],
[enable_xlib_glx=no])
-AC_ARG_ENABLE([r600-llvm-compiler],
- [AS_HELP_STRING([--enable-r600-llvm-compiler],
- [Enable experimental LLVM backend for graphics shaders @<:@default=disabled@:>@])],
- [enable_r600_llvm="$enableval"],
- [enable_r600_llvm=no])
-
AC_ARG_ENABLE([gallium-tests],
[AS_HELP_STRING([--enable-gallium-tests],
[Enable optional Gallium tests) @<:@default=disabled@:>@])],
@@ -2238,14 +2234,8 @@ if test -n "$with_gallium_drivers"; then
PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
gallium_require_drm "Gallium R600"
gallium_require_drm_loader
- if test "x$enable_r600_llvm" = xyes -o "x$enable_opencl" = xyes; then
- radeon_llvm_check "r600g"
- LLVM_COMPONENTS="${LLVM_COMPONENTS} bitreader asmparser"
- fi
- if test "x$enable_r600_llvm" = xyes; then
- USE_R600_LLVM_COMPILER=yes;
- fi
if test "x$enable_opencl" = xyes; then
+ radeon_llvm_check "r600g"
LLVM_COMPONENTS="${LLVM_COMPONENTS} bitreader asmparser"
fi
;;
@@ -2416,7 +2406,6 @@ AM_CONDITIONAL(NEED_RADEON_DRM_WINSYS, test "x$HAVE_GALLIUM_R300" = xyes -o \
"x$HAVE_GALLIUM_RADEONSI" = xyes)
AM_CONDITIONAL(NEED_WINSYS_XLIB, test "x$NEED_WINSYS_XLIB" = xyes)
AM_CONDITIONAL(NEED_RADEON_LLVM, test x$NEED_RADEON_LLVM = xyes)
-AM_CONDITIONAL(USE_R600_LLVM_COMPILER, test x$USE_R600_LLVM_COMPILER = xyes)
AM_CONDITIONAL(HAVE_GALLIUM_COMPUTE, test x$enable_opencl = xyes)
AM_CONDITIONAL(HAVE_MESA_LLVM, test x$MESA_LLVM = x1)
AM_CONDITIONAL(USE_VC4_SIMULATOR, test x$USE_VC4_SIMULATOR = xyes)