summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-10-01 13:28:51 -0700
committerMatt Turner <mattst88@gmail.com>2013-01-22 14:33:38 -0800
commit2a710543968b6710368d53dbff350d2d23e08268 (patch)
tree4f523022064ef6b79c20e01ce5e46c9a2a4e81fd /configure.ac
parentb68b85224d38fe9c1f6e10af338e1ff2519e689b (diff)
build: Use AX_PROG_FLEX
Tested-by: Andreas Boll <andreas.boll.dev@gmail.com> Reviewed-by: Eric Anholt <eric@anholt.net> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=47248
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 70599e1d33e..e769edadb78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,9 @@ LT_INIT([disable-static])
AX_PROG_BISON([],
AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"]
[AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))
-AC_PROG_LEX
+AX_PROG_FLEX([],
+ AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-lex.c"]
+ [AC_MSG_ERROR([flex not found - unable to compile glcpp-lex.l])]))
AC_PATH_PROG([PERL], [perl])