summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Vesely <jan.vesely@rutgers.edu>2016-02-12 18:58:55 -0500
committerJan Vesely <jan.vesely@rutgers.edu>2016-02-16 10:09:33 -0500
commit04085afcbfc01841f236884eb81e12e2fabc8c31 (patch)
tree679df078bc8c132fbcec06a70cfa0a24e4f48053 /configure.ac
parent0bba5ca468cdcd1f6f9bb6736c8a75e43fbe0cd5 (diff)
configure: Bail out on llvm-config component error
Signed-off-by: Jan Vesely <jan.vesely@rutgers.edu> Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2750d4d56c7..57330cb55cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2295,6 +2295,9 @@ dnl in LLVM_LIBS.
if test "x$MESA_LLVM" != x0; then
+ if ! $LLVM_CONFIG --libs ${LLVM_COMPONENTS} >/dev/null; then
+ AC_MSG_ERROR([Calling ${LLVM_CONFIG} failed])
+ fi
LLVM_LIBS="`$LLVM_CONFIG --libs ${LLVM_COMPONENTS}`"
dnl llvm-config may not give the right answer when llvm is a built as a