summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Dietrich <marvin24@gmx.de>2017-02-27 16:35:13 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-03-01 13:22:48 +0000
commit64b215223fb4e4559b30f9eb923c2860373a6e51 (patch)
tree6c751db834621778cc892e9f608c493bc8c06dcc /configure.ac
parentbe8aa76afd2cc5326c9d9d59c591e06365c5f618 (diff)
r600g: fix build without opencl and static llvm libs
radeon_llvm_check and friends were never called in the no-opencl case, which ended up with an empty llvm module list. As --enable-opencl always requires --enable-llvm, we can use the latter as the guard. Signed-off-by: Marc Dietrich <marvin24@gmx.de> [Emil Velikov: commit message polish] Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 890a37999cf..a3d1a00bdd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2297,7 +2297,7 @@ if test -n "$with_gallium_drivers"; then
HAVE_GALLIUM_R600=yes
PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
require_libdrm "r600"
- if test "x$enable_opencl" = xyes; then
+ if test "x$enable_llvm" = xyes; then
radeon_llvm_check $LLVM_REQUIRED_R600 "r600"
llvm_add_component "asmparser" "r600"