summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinson Lee <vlee@freedesktop.org>2017-03-16 15:26:18 -0700
committerVinson Lee <vlee@freedesktop.org>2017-03-21 23:56:17 -0700
commit62c48ccb413bbb0d3d305966514b7783640eaf89 (patch)
tree04c554057250dd7185d434f2f518d9cf9f60da60 /configure.ac
parent44ac618a4169c3ca35ec70dddac07d3e5346685a (diff)
configure.ac: Use POSIX compatible regex for word boundary.
Fixes build error on Mac OS X. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=100236 Suggested-by: Jan Beich <jbeich@freebsd.org> Suggested-by: Michel Dänzer <michel@daenzer.net> Signed-off-by: Vinson Lee <vlee@freedesktop.org> Reviewed-by: Eric Engestrom <eric@engestrom.ch> Acked-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 8c9d756f294..dbf0bf83185 100644
--- a/configure.ac
+++ b/configure.ac
@@ -907,19 +907,19 @@ llvm_add_target() {
# Call this inside ` ` to get the return value.
# $1 is the llvm-config command with arguments.
strip_unwanted_llvm_flags() {
- # Use \> (marks the end of the word)
- echo " `$1`" | sed -E \
+ echo " `$1` " | sed -E \
-e 's/[[[:space:]]]+-m[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-DNDEBUG\>//g' \
- -e 's/[[[:space:]]]+-D_GNU_SOURCE\>//g' \
- -e 's/[[[:space:]]]+-pedantic\>//g' \
+ -e 's/[[[:space:]]]+-DNDEBUG[[[:space:]]]//g' \
+ -e 's/[[[:space:]]]+-D_GNU_SOURCE[[[:space:]]]//g' \
+ -e 's/[[[:space:]]]+-pedantic[[[:space:]]]//g' \
-e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
-e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
-e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
- -e 's/-fno-rtti\>/-Fno-rtti/g' \
+ -e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
-e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
- -e 's/-Fno-rtti\>/-fno-rtti/g' \
- -e 's/^[[[:space:]]]//'
+ -e 's/-Fno-rtti[[[:space:]]]/-fno-rtti /g' \
+ -e 's/^[[[:space:]]]//' \
+ -e 's/[[[:space:]]]$//'
}
llvm_set_environment_variables() {