summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLeo Liu <leo.liu@amd.com>2017-02-23 13:37:58 -0500
committerLeo Liu <leo.liu@amd.com>2017-02-24 09:48:47 -0500
commit5398d006de3d2bd668e3fc4b80a3de0c101a3e43 (patch)
tree902fdd356cdf5bf71aa1728ff2a262dbef58f427 /configure.ac
parent3cc33e7640114de3ea3f0618385fdd0ddffef13f (diff)
configure.ac: check require_basic_egl only if egl enabled
Otherwise the configuration fails when building independant libs like vdpau, vaapi or omx Fixes: 1ac40173c2a ("configure.ac: simplify EGL requirements for drivers dependent on EGL") Signed-off-by: Leo Liu <leo.liu@amd.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Cc: "17.0" <mesa-stable@lists.freedesktop.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 44c788377b2..890a37999cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2310,7 +2310,9 @@ if test -n "$with_gallium_drivers"; then
PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
require_libdrm "radeonsi"
radeon_llvm_check $LLVM_REQUIRED_RADEONSI "radeonsi"
- require_basic_egl "radeonsi"
+ if test "x$enable_egl" = xyes; then
+ require_basic_egl "radeonsi"
+ fi
;;
xnouveau)
HAVE_GALLIUM_NOUVEAU=yes