summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-04-13 19:47:17 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-04-17 12:05:10 +0100
commit3bcef6aa245e269ee6ea3ef347148553e80e6df0 (patch)
treef67917149e78d6ee5b0d5725caaf4bb5a9febcf9 /configure.ac
parent39c3482205eb76044661a5717ddae5c674bb59c7 (diff)
configure.ac: honour --disable-libunwind if the .pc file is present
We should check the presence in order to determine if we should [implicitly] set the CFLAGS/LIBS v2: Drop spurious OMX hunk (Eric) Cc: Eric Anholt <eric@anholt.net> Reported-by: Eric Anholt <eric@anholt.net> Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ef19733423e..ab33ca03805 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1074,12 +1074,13 @@ AC_ARG_ENABLE([libunwind],
[LIBUNWIND="$enableval"],
[LIBUNWIND="auto"])
-PKG_CHECK_MODULES(LIBUNWIND, libunwind, [HAVE_LIBUNWIND=yes], [HAVE_LIBUNWIND=no])
+PKG_CHECK_EXISTS(libunwind, [HAVE_LIBUNWIND=yes], [HAVE_LIBUNWIND=no])
if test "x$LIBUNWIND" = "xauto"; then
LIBUNWIND="$HAVE_LIBUNWIND"
fi
if test "x$LIBUNWIND" = "xyes"; then
+ PKG_CHECK_MODULES(LIBUNWIND, libunwind)
if test "x$HAVE_LIBUNWIND" != "xyes"; then
AC_MSG_ERROR([libunwind requested but not installed.])
fi