summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2015-09-16 15:51:00 -0400
committerEric Anholt <eric@anholt.net>2015-09-16 15:54:00 -0400
commitf5b26b47444bac7334a3351d1f08d83d4545869c (patch)
treeb078ecd30b7e28e13f21b01002e7955ea63c5fc8 /configure.ac
parent37d0becfd91c0bb8202dd6994b6bba7e5d761990 (diff)
vc4: Only build in simulator mode if we find pkg-config for it.
This will let other developers build it x86 for build-testing purposes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 71c9b6c97fa..1ef5fbc9c08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2161,11 +2161,8 @@ if test -n "$with_gallium_drivers"; then
gallium_require_drm "vc4"
gallium_require_drm_loader
- case "$host_cpu" in
- i?86 | x86_64 | amd64)
- USE_VC4_SIMULATOR=yes
- ;;
- esac
+ PKG_CHECK_MODULES([SIMPENROSE], [simpenrose],
+ [USE_VC4_SIMULATOR=yes], [USE_VC4_SIMULATOR=no])
;;
*)
AC_MSG_ERROR([Unknown Gallium driver: $driver])