summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <jsg@jsg.id.au>2015-10-10 17:42:40 +1100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-10-21 14:09:38 +0100
commit99c4079c37ac04a0dad4ead3117f786706c80aaf (patch)
treeb323e48289d8a6a85b10f99f012d30d675bce032 /configure.ac
parentee77796a5c97105bf7e92e3a7931ee0f331a0545 (diff)
configure.ac: ensure RM is set
GNU make predefines RM to rm -f but this is not required by POSIX so ensure that RM is set. This fixes "make clean" on OpenBSD. v2: use AC_CHECK_PROG Signed-off-by: Jonathan Gray <jsg@jsg.id.au> CC: "10.6 11.0" <mesa-stable@lists.freedesktop.org> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0a3329021c0..d3df1955d26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,8 @@ AC_SYS_LARGEFILE
LT_PREREQ([2.2])
LT_INIT([disable-static])
+AC_CHECK_PROG(RM, rm, [rm -f])
+
AX_PROG_BISON([],
AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"],
[AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))